Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

Blank Screen

Lx2m3

Member
Jul 4, 2019
244
71
Rugby
Entering the car this morning was faced with a blank screen, had this before but just for a few seconds, assuming wake up time delay. On this occasion however the screen remained black. There was no change after waiting patiently for a few minutes - so a re-boot seemed the only option, which did bring it back to life. This was following a charge overnight, if that’s relevant. I’m on 2020.28.5.
Anybody else had this?
 

Avendit

Member
Apr 18, 2019
791
516
EDI
had this maybe twice? in 8 months of ownership. Sucks, but not as bad as the crashed radio/GPS module does (also twice, different occasions).
 

Tabular

New Member
May 20, 2020
4
1
Uk
M3 LR. This has happened to us at least three times in the last month. Twice on the drive, once whilst supercharging.
Today unlocked via phone, entered vehicle unlocked charge port via screen and unplugged, shut car door, car locks, opened car got in and screen blank; stayed blank for a few mins. No response from app. Exiting vehicle and using key card made no difference. Did a soft reset and it woke up.
3 days ago whilst supercharging - left car then returned to it unlocked with phone and screen blank - restarted of its own accord after min or two.
Week or so ago, on drive, after entering, exiting and unplugging - reset itself after about 90 secs.
Unnerving and getting worse? 2020.28.6
 

Medved_77

TM3 SR+ | MSM+Black | No FSD
Jan 20, 2020
2,001
1,974
Scotland
M3 LR. This has happened to us at least three times in the last month. Twice on the drive, once whilst supercharging.
Today unlocked via phone, entered vehicle unlocked charge port via screen and unplugged, shut car door, car locks, opened car got in and screen blank; stayed blank for a few mins. No response from app. Exiting vehicle and using key card made no difference. Did a soft reset and it woke up.
3 days ago whilst supercharging - left car then returned to it unlocked with phone and screen blank - restarted of its own accord after min or two.
Week or so ago, on drive, after entering, exiting and unplugging - reset itself after about 90 secs.
Unnerving and getting worse? 2020.28.6
It's worth trying the 'harder' reset that includes pressing the brake pedal down whilst waiting for the Tesla logo to appear. Also, if you have a SSD or USB Thumbdrive attached you may want to monitor the frequency of the blank screen issue without those devices plugged in. Otherwise, suggest you raise a service appointment.

Good luck getting it resolved!
 

Tabular

New Member
May 20, 2020
4
1
Uk
It's worth trying the 'harder' reset that includes pressing the brake pedal down whilst waiting for the Tesla logo to appear. Also, if you have a SSD or USB Thumbdrive attached you may want to monitor the frequency of the blank screen issue without those devices plugged in. Otherwise, suggest you raise a service appointment.

Good luck getting it resolved!
Thanks for those ideas, there is a USB drive plugged in - has been for a while - but will look to remove it and see if that makes a difference. cheers
 

tomorrowman

Member
Mar 10, 2020
254
211
Hampshire
I've had the screen buzz and go blank multiple time a day when it gets particularly - a pain when you are driving an unknown route and your satnav vanishes (as wsell as you indicators, speed indication etc etc). Always comes back after 2 mins.

Had booked in for a service, but removal of my jeda USB hub, wireless pad and a dodgy frayed USB cable seemed to sort it so cancelled.

Think USB cable was shorting causing display to have a heart attack :p
 

nightowl

Member
Sep 2, 2019
335
229
Berkshire
I'm on 2020.28.6, haven't driven much (if at all?) since updating.

In case relevant: Sentry mode is OFF, also I had unplugged the car before the recent thunderstorms (probably not necessary but better to be safe.) So it was unplugged for several days. I have a Samsung SSD plugged in.

Drove somewhere yesterday, screen was blank upon opening the door. After a minute or so, the T logo appeared and it started up.

On the return journey I had exactly the same thing upon entering the car.

Car wakes up fine from app when I'm not inside it. App seems unresponsive whilst screen is blank.
 

drtimhill

Active Member
Apr 25, 2019
1,749
2,127
Seattle
It's worth trying the 'harder' reset that includes pressing the brake pedal down whilst waiting for the Tesla logo to appear. Also, if you have a SSD or USB Thumbdrive attached you may want to monitor the frequency of the blank screen issue without those devices plugged in. Otherwise, suggest you raise a service appointment.

Good luck getting it resolved!

The brake pedal thing has been pretty much debunked .. there is no evidence it does anything.
 
  • Like
Reactions: Rooster6655

nightowl

Member
Sep 2, 2019
335
229
Berkshire
The brake pedal thing has been pretty much debunked .. there is no evidence it does anything.

I had an issue a few months ago where the car was not "seeing" anything. The display just showed my car. No edge of the road, no lane markings, no other cars... And it wouldn't offer autopilot functionality. For the entire journey on the way home from work. Tried a two-button reboot and the problem remained. Someone on here suggested holding brake pedal as well and that fixed the problem.
 
  • Informative
Reactions: X-pilot and Avendit

Tabular

New Member
May 20, 2020
4
1
Uk
I've had the screen buzz and go blank multiple time a day when it gets particularly - a pain when you are driving an unknown route and your satnav vanishes (as wsell as you indicators, speed indication etc etc). Always comes back after 2 mins.

Had booked in for a service, but removal of my jeda USB hub, wireless pad and a dodgy frayed USB cable seemed to sort it so cancelled.

Think USB cable was shorting causing display to have a heart attack :p
Not had a blank screen whilst actually driving - I’d be having the heart attack let alone the screen!
 

kuruma

Member
Aug 29, 2019
286
125
Northeast
It's worth trying the 'harder' reset that includes pressing the brake pedal down whilst waiting for the Tesla logo to appear.
For the first time, had the blank screen happen to us as we were late for an important meeting the other day. Got in the car and everything seemed to be fine except the screen. Nothing would work to make the screen come on, even a hard reset with the addition of the brake. I held that thing down for minutes (literally) and nothing happened. Was getting frustrated and just about to settle for driving half an hour without a speedo when all of a sudden the logo appears and everything returns to normal. Didn't have my foot on the brake at that point though so maybe a butterfly landed on a leaf in Peru or something. No idea what caused it or uncaused it.
 
  • Funny
Reactions: X-pilot

Rooster6655

Active Member
May 3, 2019
1,521
527
UK
Yeah have this problem, its ridiculous, as well as blank screen whilst driving, how can this even be acceptable, can't see the speedo? well clearly this is not safe or likely legal to drive with a blank screen.

Even if its the USB that is still not acceptable that the screen goes blank and there should be safe guards in place, really not impressed with this.

Thinking of getting a third party screen for readout information so won't have to deal with a blank screen again.
 
  • Like
Reactions: X-pilot and Neilio

Tabular

New Member
May 20, 2020
4
1
Uk
Can’t even drive ours if blank screen happens as use PIN to drive, no inputting pin, no drivin’
Hasn’t happened since my soft reset... *touches wood*
 
  • Like
Reactions: X-pilot

VanillaAir_UK

Supporting Member
Jun 17, 2019
7,777
5,228
Surrey, UK
Blank screen first thing this morning :( Cleared with a soft reset :rolleyes:

Hopefully its a one off software related fault.

2020.32.3; left overnight; no charging involved.

upload_2020-8-28_9-27-22.png
 

tomorrowman

Member
Mar 10, 2020
254
211
Hampshire
I've had the screen buzz and go blank multiple time a day when it gets particularly - a pain when you are driving an unknown route and your satnav vanishes (as wsell as you indicators, speed indication etc etc). Always comes back after 2 mins.

Had booked in for a service, but removal of my jeda USB hub, wireless pad and a dodgy frayed USB cable seemed to sort it so cancelled.

Think USB cable was shorting causing display to have a heart attack :p

I spoke to soon, had screen go blank on me twice since while driving (though without the loud buzzing noise). I'll try the 'remove your USB stick' option and see if in conjunction with this new 2020.32.3 update the problem goes away - If not rebook service appointment (I really don't want to drive from Basingstoke to West Drayton to get it fixed !!!)
 

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top