Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

Front Safety Restraint System Fault Refresh S

They were able to fix it. After 3 hours of trying to figure it out, they spoke with a mechanic at the factory and he guided them to a loose connector or electrical complement.

Can't believe they couldn't easily figure it out (maybe new car model). I have searched and it seems that people have these issues with other tesla models, like the MY. People either replaced harness or reconnected the connector, i was trying to get under the seat to see the connector and thinking about disconnecting and connecting it back.

Do you have a detailed description of what they did?
 
A00BA707-4DF0-48E7-B877-7656D04C7115.jpeg
 

WiLz

Member
Jun 20, 2021
103
412
California
Initially scheduled a mobile visit for this, but got a call few days before appointment saying they ran diagnostics on the car and need to replace the front airbag module, but the part has ETA 10 days out. Was told I can either keep driving my car with a potentially nonfunctional airbag until the part comes, or drop off my car at service and they will give me loaner to drive while waiting. Went with the second option given the safety concern. Dropped off car Thursday, expecting car to be there for at least 10 days, but got a message Friday evening saying they were able to get the part and car is done. Will go pick up the car in the morning and see what they ended up doing, and post an update later.
 
  • Like
Reactions: yayarearunner

WiLz

Member
Jun 20, 2021
103
412
California
Here’s what they supposedly did. Sounds like they’re not really sure what the problem is, but it’s resolved for now:

Concern: Customer states - Recent alerts, on screen stats ''Safety restraint system fault/Contact Tesla Service''

Verified concern. Noted that alerts shows theres an open somewhere up to the drivers airbag. Suspect components are RCM, wiring, clock spring, and airbag. Removed the airbag and clock spring. Tested the airbag and it had shown < 1ohms of resistance. Tested circuits through the clock spring and they were also <1ohm.Isolated the wiring from the RCM to the clock spring and it tested out ok at <1ohm. Due to known previous issues, disconnected connector X947. Tested for pin drag issues but all tested ok. At this point, Diagnosis is inconclusive, but because X947 is a known issue, applied dielectric grease to the pins and reseated the connector. Reassembled the vehicle and performed longer test drive. Alerts did not return. Repair verified at this point.
 
I "picked it up" today but had to leave it since it had a mark that they are going to polish out tomorrow. But this was the main reason my car was in for the past two weeks along with a laundry list of small issues I wanted them to fix including panel gaps and rear hatch alignment issues.

But they spoke with engineering and had to replace the dashboard harness which was a larger job then they anticipated. I will upload a screen capture of the section when I get access again after I pick up my car tomorrow.
 
Car now back in shop for same issue. Lame. Told they couldn’t fix. Giving me a garbage loaner for now.
Update: told me they had to order a new safety harness. Will take a week or two. They wanted to give me a loaner but I asked for my car back and they did after I signed a waiver. The supervising mechanic was actually very cool about the whole thing and took the time to explain everything.
 
  • Like
Reactions: yayarearunner

Epic Plaid

New Member
Sep 12, 2021
1
0
Canton Ga
I took delivery of my S Plaid Aug 2nd. I appears I have the same issue. The warning stays on my dash though and never goes off. I hope they have figured this out. The crazier thing is I can’t get it in for service for over a week and I have 4 service centers around me. Wish me luck!!
 
Update: told me they had to order a new safety harness. Will take a week or two. They wanted to give me a loaner but I asked for my car back and they did after I signed a waiver. The supervising mechanic was actually very cool about the whole thing and took the time to explain everything.
Took it back, could not resolve issue by swapping out harness. Wanted to keep it. Didn’t let them keep it. Bringing it back in a couple weeks. 6 visits to the shop for stuff.
 
Front Passenger safety restraint system fault/service required Could not get a service appt until Oct 27....and it means a round trip of 200 miles and no guarantee of how long we would be there in SLC. that means driving for 2 weeks without the airbag function!! They did not offer to send a mechanic to our place in Preston, Idaho. Poor service on our Y. Will try to get into the Las Vegas service center after Nov 1.
 

markinva

New Member
Aug 18, 2021
3
0
20148
I also got a couple airbag error codes/airbag light on my new model S plaid. It's been at the service senter for 12 days now and currently still no ETA on the 2 airbags they had to order. I'm wondering if I'm in for a huge delay because of supply chain issues or something. I have no idea if the car will be ready tomorrow or if it will take weeks. Quite frustrating. And I'm wondering if they are going to have to order a wiring harness, next.
 

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top