Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register
  • Want to remove ads? Register an account and login to see fewer ads, and become a Supporting Member to remove almost all ads.
  • The final cut of TMC Podcast #27 is available now with topics time-stamped. We discussed: Consolidation in LiDAR manufacturers; Volvo EX90 shipping with LiDAR; FSD Beta Full Release in N.A.; FSD detecting autopilot cheats, Gwen Shotwell directly overseeing SpaceX Starship; and more. You can watch it now on YouTube. We should have it published to podcast networks shortly.

rear view camera not working

Same exact issue, seems like the recent firmware update caused it. I've already tried hard reset disconnected 12v and from rear seat issue still remain. Please report back if SC is able to resolve your issue. My only concern is that we have aftermarket power trunk and if SC going to make that an issue of concem
Same exact issue, seems like the recent firmware update caused it. I've already tried hard reset disconnected 12v and from rear seat issue still remain. Please report back if SC is able to resolve your issue. My only concern is that we have aftermarket power trunk and if SC going to make that an issue of concern.
my Hansshow v4 broke and I installed the v6 a month ago. Sounds like we have something in common.
 

smatthew

Active Member
Jun 9, 2018
1,535
2,574
CA Bay Area
Hello,

I have exact same issue right after installing a Hansshow V6 kit. After a night of sleep backup camera works properly. If I use the trunk, the backup camera turns to black when I open via the icon, or reverse.

Do you have the same issue ?
You messed up the trunk harness when you were fishing the wires. Luckily it's only $70 to buy and install yourself.
 
  • Like
Reactions: NoMoreBMWs
After further diagnosis, I think hansshow trunk kit (I have v3 of the kit) may be the issue with the latest firmware (2021.4.18.2)... I checked the wires behind the rubber tube nothing looks damaged.

I opened the trunk and reset camera calibration and was able to observe the camera turning on and off whenever the "OPEN" and "CLOSE" toggling back and forth. I've disconnected hansshow wiring on my trunk and wait for deep sleep for camera to turn back on, then to retest opening trunk without hansshow installed.

Sigh.. hansshow support is pretty much non existence, probably should of went with Tesla Offer's Trunk kit.
 
Another update of investigation, after connecting the original wire harness on the trunk.
Whenever I push the trunk button on the trunk, it flashes black for a few second and comes back online. Did this multiple times result is the same but at least the camera is up and running after that blackout. This does explains why the camera was going "ON" and "OFF" with hansshow electric tailgate due to toggling back and forth "OPEN", "CLOSE". I think the trunk loses some sort of power for a brief second when opening since this update.

I cannot confirm if this happens on previous firmware but I assume not since it never happened before. Anyways I concluded this is a software issue on current frimware (2021.4.18.2) with hansshow electric tailgate. Hopefully future update fixes it, but I decided I'm going to purchase Tesla Offer's electric tailgate to replace it and hopefully that fixes it as well.
 
Last edited:
Another update of investigation, after connecting the original wire harness on the trunk.
Whenever I push the trunk button on the trunk, it flashes black for a few second and comes back online. Did this multiple times result is the same but at least the camera is up and running after that blackout. This does explains why the camera was going "ON" and "OFF" with hansshow electric tailgate due to toggling back and forth "OPEN", "CLOSE". I think the trunk loses some sort of power for a brief second when opening since this update.

I cannot confirm if this happens on previous firmware but I assume not since it never happened before. Anyways I concluded this is a software issue on current frimware (2021.4.18.2) with hansshow electric tailgate. Hopefully future update fixes it, but I decided I'm going to purchase Tesla Offer's electric tailgate to replace it and hopefully that fixes it as well.
Hello,

thanks for your feedback. My harness is also not damaged.

I also have the opinion that it is more related to a software bug. Is your V3 connected to the CAN Bus ? Mine is not and so I see the trunk on the screen bouncing between Opened and Closed states. I might also give a shot and connect to the CAN Bus, see if it improves.
 
Hello,

thanks for your feedback. My harness is also not damaged.

I also have the opinion that it is more related to a software bug. Is your V3 connected to the CAN Bus ? Mine is not and so I see the trunk on the screen bouncing between Opened and Closed states. I might also give a shot and connect to the CAN Bus, see if it improves.
Nope, do not have a CANBUS connector to test, since my kit was before they started doing that. I will be receiving my tesla offer version of the trunk kit very soon and reinstall and hope it fixes it.
 
Update

from my observations and posts from @12seconds, I can also see the rear camera turning to black when trunk switches to CLOSE state on the screen. This is clear in the video below.


I have the V6 kit but had not plugged the CAN Bus. When I close the trunk while screen is turned off, then it stays permanently off for the next drive(s). It comes back on after a deep sleep.

I plugged the CAN Bus yesterday evening and now the trunk on the screen no longer bounces between OPENED and CLOSED states. Camera seems also more stable but I need a couple of days to confirm that.
I lost the ability to Close from the screen but I'd rather keep the camera on at the moment :)
 
  • Like
Reactions: 12seconds
Update

from my observations and posts from @12seconds, I can also see the rear camera turning to black when trunk switches to CLOSE state on the screen. This is clear in the video below.


I have the V6 kit but had not plugged the CAN Bus. When I close the trunk while screen is turned off, then it stays permanently off for the next drive(s). It comes back on after a deep sleep.

I plugged the CAN Bus yesterday evening and now the trunk on the screen no longer bounces between OPENED and CLOSED states. Camera seems also more stable but I need a couple of days to confirm that.
I lost the ability to Close from the screen but I'd rather keep the camera on at the moment :)
Awesome thank for reporting back, this gives me hope. Since I do not have the CANBUS connector for hansshow, EVOffer should resolves my issue.

Hopefully our observations and investigations help anyone else with this issue.
 

shrink

Member
Supporting Member
May 21, 2013
930
446
Phoenix, AZ
I started having these same problems last week and my 12V battery ended up dying Saturday night. I received no warning alerts prior to the battery dying. I have Hansshow V3 frunk and trunk openers and a 2020 Model 3 that’s only about 18 months old.

Tesla was just here to replace the battery. I’m seeing exactly what @JD_TM3 posted when I have the cameras up and open/close the trunk after the new battery installation.

Any suggestions on what to do? I don’t want my battery to die again. I prefer reliable backup camera access over the convenience of the power trunk. I’m also reluctant to upgrade because I don’t trust Tesla firmware updates. I’ve had bad experiences with an old Model S and firmware updates.

I didn’t do the install, but I can follow directions pretty well. Is there an easy way to disconnect the Hansshow and re-connnect to the OEM trunk release? I can reinstall OEM struts when I have more time over the weekend.
 
I started having these same problems last week and my 12V battery ended up dying Saturday night. I received no warning alerts prior to the battery dying. I have Hansshow V3 frunk and trunk openers and a 2020 Model 3 that’s only about 18 months old.

Tesla was just here to replace the battery. I’m seeing exactly what @JD_TM3 posted when I have the cameras up and open/close the trunk after the new battery installation.

Any suggestions on what to do? I don’t want my battery to die again. I prefer reliable backup camera access over the convenience of the power trunk. I’m also reluctant to upgrade because I don’t trust Tesla firmware updates. I’ve had bad experiences with an old Model S and firmware updates.

I didn’t do the install, but I can follow directions pretty well. Is there an easy way to disconnect the Hansshow and re-connnect to the OEM trunk release? I can reinstall OEM struts when I have more time over the weekend.
What firmware are you currently on?

I am pretty sure this is a firmware (2021.4.18.x) issue, I am assuming they did something with the firmware for 2021 OEM power trunk. I think there's a disconnect in power momentary on the trunk harness when you open it. I can confirm that I don't have any damage on my OEM trunk harness I tested the continuity on each wires. Hopefully this will be fixed on later firmware. According to @JD_TM3 adding CANBUS fixes the black screen issue when opening trunk, so perhaps maybe you can order a CANBUS harness from hansshow?

If you want to go back to OEM, you would need to replace the struts and the trunk latch hook. I gotta say removing the hansshow struts (or EVOffer struts) isn't easy for the bottom part since you don't have any room to put flat head screw driver in, you'd need to find some kind of hook with flat end to pry it. Took me awhile to get it out and being very careful not to use too much force to open it so it doesn't hit the glass. Also depending on how your installer wired the struts you may have to drop the bumper.

Anyways, I replaced my hansshow power trunk to EVOffer(Tesla Offer) power trunk today and quite happy with it. I don't experience anymore black screen although there is black screen momentary when you open or close it but it doesn't cut off the power of the rear camera. Hoping it stays this way, and tesla fix their firmware for that short blackout.
 

shrink

Member
Supporting Member
May 21, 2013
930
446
Phoenix, AZ
What firmware are you currently on?

I am pretty sure this is a firmware (2021.4.18.x) issue, I am assuming they did something with the firmware for 2021 OEM power trunk. I think there's a disconnect in power momentary on the trunk harness when you open it. I can confirm that I don't have any damage on my OEM trunk harness I tested the continuity on each wires. Hopefully this will be fixed on later firmware. According to @JD_TM3 adding CANBUS fixes the black screen issue when opening trunk, so perhaps maybe you can order a CANBUS harness from hansshow?

If you want to go back to OEM, you would need to replace the struts and the trunk latch hook. I gotta say removing the hansshow struts (or EVOffer struts) isn't easy for the bottom part since you don't have any room to put flat head screw driver in, you'd need to find some kind of hook with flat end to pry it. Took me awhile to get it out and being very careful not to use too much force to open it so it doesn't hit the glass. Also depending on how your installer wired the struts you may have to drop the bumper.

Anyways, I replaced my hansshow power trunk to EVOffer(Tesla Offer) power trunk today and quite happy with it. I don't experience anymore black screen although there is black screen momentary when you open or close it but it doesn't cut off the power of the rear camera. Hoping it stays this way, and tesla fix their firmware for that short blackout.
I’m on 2021.4.21.2

My installer is nearby. I can easily ask him to take me back to stock, but I’ll try reaching out the Hansshow first RE: a CANBUS upgrade. I can pull off panels and wire that.

Would it be possible to unplug the Hansshow tailgate handle Y-adapter and reconnect the OEM wiring?

I’m guessing the Hansshow power struts will still move without power, albeit not as smoothly and easily as the non-powered OEM ones.

What a hassle. This has been working perfectly ever since installation 1-1/2 years ago.

Tesla firmware has a bad habit of breaking things.
 

shrink

Member
Supporting Member
May 21, 2013
930
446
Phoenix, AZ
I ended up disconnecting the Hansshow v3 Tailgate and went back to stock. I was able to do it myself, but it took a while. Pulling off and re-installing all those interior panels is best left to the professionals and there is, indeed, not a lot of room to release the lower portion of the struts.

I kept getting intermittent back up camera errors. Sentry mode videos were just a black screen as well.

I did reach out to Hansshow and they tried to blame it on the original equipment failing despite me saying everything was working normally once I disconnected their equipment. They did not want to listen to a potential CANBUS connection solution, nor do they want to update their firmware. Tesla has no reason to fix this, so while I'm hopeful for other owners who have this installed, I am not confident. Tesla firmware and 3rd party accessories do not play well historically.
 
My backup camera was intermittent when we first got the car in 2018 but it got better and better over the years, until the past 6 months. Now it's gotten to the point where it basically never works.

Trying to take the car into the service center, gave them my list of 6 or 8 issues, most of them minor, to get looked at before the warranty is up in another thousand miles.

First thing they want to do is bill me for diagnosis for virtually every issue I cited, emailed me a form to e-sign to consent to all their charges. Fun times. Trying to figure out how to deal with it now, been going back and forth via messages, but I'm hoping I can just bring the damn car in to the appointment next week without signing anything.

Plus telling me fit-and-finish things would only be covered in the first 10k miles. Well, no wonder nobody ever wants to take their car to get serviced.
 
I had done the steering wheel button reboot and the brake+steering wheel button reboots with no luck. The camera was out for a full day. No rear backup camera, and no rear camera in dash cam or sentry mode recordings. I turned off sentry mode entirely and let the car sit overnight (thanks, @Sam1). The next morning, the rear camera was back to normal again.
 
  • Like
Reactions: Sam1
Update

from my observations and posts from @12seconds, I can also see the rear camera turning to black when trunk switches to CLOSE state on the screen. This is clear in the video below.


I have the V6 kit but had not plugged the CAN Bus. When I close the trunk while screen is turned off, then it stays permanently off for the next drive(s). It comes back on after a deep sleep.

I plugged the CAN Bus yesterday evening and now the trunk on the screen no longer bounces between OPENED and CLOSED states. Camera seems also more stable but I need a couple of days to confirm that.
I lost the ability to Close from the screen but I'd rather keep the camera on at the moment :)
Sadly I must report that the problem happens again. I feel it is less often but still there.
I wish newer firmwares fix this camera going on/off because that seems to be the origin of the problem.
 

smatthew

Active Member
Jun 9, 2018
1,535
2,574
CA Bay Area
Hello,

thanks for your feedback. My harness is also not damaged.

I also have the opinion that it is more related to a software bug. Is your V3 connected to the CAN Bus ? Mine is not and so I see the trunk on the screen bouncing between Opened and Closed states. I might also give a shot and connect to the CAN Bus, see if it improves.
How do you know your harness isn't damaged? The damage would be hidden inside the flexible rubber tube and would be intermittent. Those wires are very small and very easy to accidentally damage, then the motion of the trunk finishes them off.
 
Hi everyone,

I'm new to this forum and just got my new model 3 delivered about 3 weeks ago.
So far I have been very happy with car with one exception : the rear view camera. I know there are a few posts on this forum and the now read-only Tesla one, but I don't see a lot of recent complaints on it.
I then wonder, if there are other new 2021 owners that have similar issues than mine:
- rear view camera usually works after the car has been parked overnight
- all of a sudden it could turn black
- "rebooting" the car doesn't help
- powering off the car doesn't help
- removing USB key, turning off sentry mode doesn't help

Mobile Service came twice already. The first time they re-pushed the latest firmware, although I was already on it --> it did not help.
The second time, they replaced the camera itself --> worked flawlessly for one day, but I have the issue again.
I'm waiting for them to get back again, but I guess the next thing would be a trip to the SC.

Does anyone has similar issues with newer models ? I see similar complaints in 2018 but I would hope it would have been fixed 3 years later...

Thank you.
Just took my Model Y (received delivery Oct., 2020) into the Tesla service center, initially for a recall inspection, but as un-luck would have it, the rear back up camera went black on me a couple of days ago, followed shortly thereafter by the GPS/navigation system malfunctioning (the red arrow that usually tracks the car's movement remained at our home address, even as I was driving or was parked at work. I tried ALL the things recommended on this and other forums (soft reset, hard reset, powered off and left overnight, removed USB, made sure sentry mode was turned off, etc.) and no dice. I took it in this morning at 9AM and just received a message from the SC that they are still working on diagnosing the problem with the rear camera and the navigation system, and will need to keep it overnight to continue work on it tomorrow. Frustrating and really inconvenient timing, as we're supposed to drive to Michigan to visit family on Saturday morning. I'm crossing my fingers that the issue is resolved by then and won't impact our travel plans. Once I find out what they determined to be the cause of the malfunctions, I'll be sure to update this post.
 

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top