TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker or making a Paypal contribution here: paypal.me/SupportTMC

Audio compilations on USB

Discussion in 'Model S: User Interface' started by ausdma, Dec 29, 2013.

  1. ausdma

    ausdma Member

    Joined:
    Sep 21, 2013
    Messages:
    120
    Location:
    Austin, TX
    Can't find this answer on searching the forums. Got a 64gb thumb drive and been putting music on it.

    I have a number of compilations (a CD with a number of songs by different artists) I like to listen to. No matter how I put them in the folder structure, when I select Albums in the UI it displays each song in the compilation as if it is a separate album. I can get to them through the Folder Structure view but the Album view is screwed up.

    Am I missing something?
     
  2. Robert.Boston

    Robert.Boston Model S VIN P01536

    Joined:
    Oct 7, 2011
    Messages:
    7,842
    Location:
    Portland, Maine, USA
    You're not missing something. Folder access is really the only reliable way to get to your music unless you are absolutely fanatical about managing the metadata tags in your files. There's absolutely no quality control from commercial providers on the metadata: the same artist might show up five different ways, the album field can be garbage, etc. For the compilation, you'd have to edit the metadata tags to change all the album names to be the same.
     
  3. ausdma

    ausdma Member

    Joined:
    Sep 21, 2013
    Messages:
    120
    Location:
    Austin, TX
    Ah. It's a data problem. That makes sense.

    Thanks.
     
  4. iffatall

    iffatall Member

    Joined:
    Nov 15, 2013
    Messages:
    510
    Location:
    SF Bay Area, CA
    My guess - if you make sure every song in a given album has the exact same Album name and Album Artist attributes, the songs should be combined into one album on the interface.

    Try it out on one album, and see if it works.
     
  5. Robert.Boston

    Robert.Boston Model S VIN P01536

    Joined:
    Oct 7, 2011
    Messages:
    7,842
    Location:
    Portland, Maine, USA
    Good point -- album and artist has to match (so that everyone's "Greatest Hits" don't end up in the same album).
     
  6. iffatall

    iffatall Member

    Joined:
    Nov 15, 2013
    Messages:
    510
    Location:
    SF Bay Area, CA
    Exactly.

    By the way, I just want to clarify - I was talking about the "Album" and "Album Artist" attributes. We have to be careful when talking about this because "Artists" is a separate attribute that can be different for different songs within the album.
     
  7. Chico

    Chico MS P85

    Joined:
    Dec 30, 2013
    Messages:
    29
    Location:
    NorCal
    I think the real solution would be playlist support. That (and lack of shuffle) make the music player implementation mediocre, IMO.
     
  8. ausdma

    ausdma Member

    Joined:
    Sep 21, 2013
    Messages:
    120
    Location:
    Austin, TX
    So I downloaded a tag editor, MusicBrainz Picard, and did some experimenting. Sometimes I got what I wanted and sometimes I didn't.

    I have this feeling that the car must be caching the data because I can change tags and see they have been tagged on the app on my computer but the UI in the car doesn't recognize the changes.
     
  9. kirkp

    kirkp Member

    Joined:
    May 22, 2013
    Messages:
    59
    Location:
    Atlanta, GA
    I believe that the old data are cached based on the filename. If you change just one character in the name of the files whose tags have been updated, the car will recognize the updated metadata. That's been my experience at least.
     
  10. ausdma

    ausdma Member

    Joined:
    Sep 21, 2013
    Messages:
    120
    Location:
    Austin, TX
    Cool beans. I'll try that tomorrow. Rebooting the console did not do the trick. Thanks.

    Happy New Year!
     
  11. ausdma

    ausdma Member

    Joined:
    Sep 21, 2013
    Messages:
    120
    Location:
    Austin, TX
    That pretty much did it! Thanks.

    Looking pretty good overall. Still got a few issues to work out using MusicBrainz Picard but I'm on the right track now.
     
  12. Mayhemm

    Mayhemm Model S P85+ "Lola"

    Joined:
    Nov 9, 2012
    Messages:
    1,939
    Location:
    Saskatchewan, Canada
    May not matter since it doesn't sound like the tagging software is at fault, but I've always used MP3tag for my tagging (Don't let the name fool you, it works on most formats, not just MP3s)

    Didn't really care for Picard.
     
  13. ausdma

    ausdma Member

    Joined:
    Sep 21, 2013
    Messages:
    120
    Location:
    Austin, TX
    I don't do Windows these days, though when I replace my aging iMac, I may get back into Parallels world. Also tried Kid3.

    I was frustrated that I had Album name consistent but it still wasn't parsing like I thought it should. Once I figured out that for compilations the Album Artist tag needed to be consistent with something like "Various Artists" it started working a lot better. Got it going on now and it's working great!

    It's odd to me that when you select the Artist view it drills down as Artist>Album>All Tracks even if the artist only plays on one track. Seems like it would drill down as Artist>Album>Relevant Tracks.
     
  14. AoneOne

    AoneOne Member

    Joined:
    Sep 21, 2013
    Messages:
    151
    Location:
    Fox Chapel (Pittsburgh), PA
    I've been unable to get my Model S to recognize my compilations as a single artist. Here are some details:

    I'm using FLAC not MP3.

    All of the compilations have both AlbumArtist and Compilation flags sets appropriately (AlbumArtist is typically "Various Artists" and Compilation is "1"). I used MP3tag to add the compilation flags: the AlbumArtist had already been set consistently by foobar2000.



    To reset any caching I've tried renaming the audio files. I've also tried renaming the album's folder instead of the original files. Neither seemed to have any effect.

    Have you had success with compilations of FLAC-encoded audio?

    Thanks.
     
  15. AoneOne

    AoneOne Member

    Joined:
    Sep 21, 2013
    Messages:
    151
    Location:
    Fox Chapel (Pittsburgh), PA
    Bump: Anyone using FLAC in the Model S?
     
  16. iffatall

    iffatall Member

    Joined:
    Nov 15, 2013
    Messages:
    510
    Location:
    SF Bay Area, CA
    Does anyone know a way to clear the music cache. I corrected all the tags in my entire collection. But the UI still shows old tags. I don't want to go about changing the names of every single track in my collection. Any tricks anyone?
     
  17. jerry33

    jerry33 S85 - VIN:P05130 - 3/2/13

    Joined:
    Mar 8, 2012
    Messages:
    12,763
    Location:
    Texas
    Certainly. FLAC works great.
     

Share This Page