Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

Keyless Entry no longer working?

Fullerene

Member
Jul 31, 2019
372
395
Dorset, UK
This morning I went to the car and nothing. Door didn't unlock, bluetooth was connected, had keycard in pocket, got in and started with keycard.

Rebooted Car, rebooted phone, no luck, tried a few times in the past few hours. Will raise with Tesla if it doesn't come back to life later today.

Phone says connected, phone is listed in key list, car says connected.

Had a super quick search can't find any hints on this - anyone had similar?

Thanks!
 

DaveW

Active Member
May 21, 2019
1,183
938
Beds, UK
Did you get your phone out of your pocket and near the car? I find mine rarely opens when my phone is in my back pocket, seems to need to be very close!
 

pgkevet

Active Member
Jul 1, 2019
1,423
1,215
mid wales
The only time I had a problem with my S it was phone reboot that sorted it (yes I see you tried that). Perhaps unpair, reboot phone and re-pair???
 

KennethS

Supporting Member
Supporting Member
May 3, 2019
518
360
UK
Had the problem on my wife’s iPhone after she updated to iOS 13 (I have been on it since before we collected the car and my phone was still working fine, so I put 2 and 2 together). For simplicity, I deleted her phone as a key entry in the Tesla, deleted the app from her phone, reinstalled it and logged in, gave it all permissions that the phone prompted permissions for, and re-authorised in the car. Been working fine since. It may have been more steps than needed, but I tend to go back to square one when problems arise.
 
  • Like
Reactions: Roy W.

arg

Supporting Member
Supporting Member
Aug 22, 2012
1,814
1,811
Cambridge, UK
I'm failing to connect with the app at all this morning (Model S). This usually means something is broken with Tesla's cloud service (and it will come back in a bit without me doing anything).

For Model 3, keyless entry that shouldn't matter as the control is local via bluetooth, though as I understand it there's a security token that can expire and the app on the phone then needs to connect via the cloud to renew it.
 
  • Like
Reactions: Roy W.

Fullerene

Member
Jul 31, 2019
372
395
Dorset, UK
Thank you all for assistance. Keyless is now working.

I hadn't done anything unusual with phone or car between it working last night and not working this morning. Charge cable was plugged in but car wasn't charging. I hadn't used the car at all yesterday - apart from sitting in it to get SSD, check sentry footage was working and re-install SSD.

State prior to fix:
iOS was up to date 13.1, updated last before I had the car.
Tried rebooting phone and car a few times.
I haven't ever needed to remove phone from pocket to open car - it always just works.
Car parked in normal location
All other wireless seemed ok - bluetooth was working from phone to other devices.
AFAIK no Van der Graaf generators in use nearby...
App settings for Tesla App all turned on

Process that fixed for me:
Phone Bluetooth - Forget Device 'Tesla M3' - I am convinced this was how the bluetooth name was for the M3 - though I don't have a screen grab to confirm
Deleted phone from car Key list
Deleted Tesla App and all data
Reinstalled Tesla App
Logged back in
Went through pairing process with car

Keyless entry worked as per normal.

The only oddity is that the bluetooth name for my car is now a fairly long random string - I am reasonably convinced it had a friendly name before that.

I am not sure what the root cause was, kind of hoping it was situated between the driver's seat and steering wheel!

Hopefully all is well now and I will forever carry a keycard. Thanks again :)
 
  • Like
Reactions: Roy W.

Roy W.

Battery running low...
Jun 3, 2019
2,330
2,375
Derby, UK
I’ve had very occasional problems with keyless entry, pretty much since day one (five weeks now).

Most of the time the keyless entry works fine, but maybe ten times in total I’ve come to the boot or door and it stays locked. I’ve always just pulled my phone from my pocket, opened the app and opened the boot or unlocked the car from there.

Mine too is an iPhone, latest iOS, but the problem has been occurring randomly for the last five weeks, so over several phone updates. I suspect it’s a bit flakey.
 

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top