Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.

Music from USB skips

When I play music from a USB drive on my standard MS sound system, I am experiencing skips. I have tried two different USB drives from different manufacturers with the same result. Then I tried playing the music on my computer from the USB drive and there are no skips. So I am assuming the problem is in my MS sound system. The file format is wma (windows media audio). I don't see anyone else on the forum having this problem. Any ideas for solving this problem?
I had the same experience with music I stored with the standard windows media. My car just didn't seem to like the files. It would play, but there were lots of errors/skips in the Model S, but it would play just fine in my Leaf. I downloaded Freerip and have had no issues with the same music.
Yep. I'd suggest that you change the audio format. 99.9% sure that's the problem.

Agreed. In particular Apple Lossless is unplayable by the Tesla. Changing the format to FLAC works perfectly--and doesn't take very long because you can directly change other lossless formats to FLAC right on the thumb drive:

Software used:
Max (Macintosh Audio for OS X)


General: Maximum number of encoders: 2
Format: FLAC
Output files: Select your mounted thumb drive
Temporary files: Default
Delete source files after conversion: Check the box

No other preference settings need to be changed from the defaults.
When using Snow Leopard, Format will crash the app if you don't check "Start using Rosetta" in the Finder (the i icon)

Drag the directories on the thumb drive to the File Conversion window (File-->Convert files), press convert.

I'm sure there are other programs, but this was the first one I found.
My FLACs play flawlessly, but I encountered "stuttering" yesterday while playing a MP3 downsampled from a WAV file using variable rate MP3 encoding (~300kps), played from my USB. The playback kept jumping ahead seconds at a time; if I manually used the slider to restart the track into the section that was being skipped through, it played fine.
Have songs playing off my USB (lossless FLAC) without problems until I upgraded to 8.1 a few days ago. Now songs skip ahead a few seconds at a time when playing (it sounds like a pause of silence and then keeps going almost like in XM when you have a bridge block the signal for a second or two). Regular Model S (not UHFS). Anyone else seeing the same thing?