TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

TMC Navigation Update

Discussion in 'Site Feedback' started by danny, Nov 19, 2016.

  1. danny

    danny Administrator

    Joined:
    Aug 15, 2006
    Messages:
    1,138
    Location:
    California
    I've noticed something like this when having just applied the update on various test sites, but this seemed to have something to do having cleared cache, and it was really probably just that things hadn't loaded yet.

    I can't reproduce the issue you have reported. If you are able to and able to get a screencast of it, that would be very helpful.
     
  2. JRP3

    JRP3 Hyperactive Member

    Joined:
    Aug 20, 2007
    Messages:
    15,663
    Location:
    Central New York
    So far I only see it in the Short Term thread:

    Missing Nav bar.jpg
     
  3. danny

    danny Administrator

    Joined:
    Aug 15, 2006
    Messages:
    1,138
    Location:
    California
    Anyone else seeing this?
     
  4. JRP3

    JRP3 Hyperactive Member

    Joined:
    Aug 20, 2007
    Messages:
    15,663
    Location:
    Central New York
    Just happened briefly on this page as I scrolled to the bottom, bar disappeared completely, but then just as I started scrolling back up it popped back down. I think the more posts on a page the more I have to scroll back up to see it again if it disappears. Doesn't always disappear either. Using FF on Win7, maybe it's an issue on my end?
     
  5. danny

    danny Administrator

    Joined:
    Aug 15, 2006
    Messages:
    1,138
    Location:
    California
    Can you clear local cache / hard-refresh and then please let me know if it's still happening?
     
  6. JRP3

    JRP3 Hyperactive Member

    Joined:
    Aug 20, 2007
    Messages:
    15,663
    Location:
    Central New York
    Cleared browser cash, restarted browser, restarted computer, same issue. Interestingly, once I scroll back up far enough for it to appear again it remains even if I scroll back down.
     
  7. danny

    danny Administrator

    Joined:
    Aug 15, 2006
    Messages:
    1,138
    Location:
    California
    Has this happened to you when you change any one variable, such as browser, OS, computer, etc.?
     
  8. JRP3

    JRP3 Hyperactive Member

    Joined:
    Aug 20, 2007
    Messages:
    15,663
    Location:
    Central New York
    Only have regular access to one computer at the moment. I'll try switching from FF to Chrome.
     
  9. JRP3

    JRP3 Hyperactive Member

    Joined:
    Aug 20, 2007
    Messages:
    15,663
    Location:
    Central New York
    One consistent difference I've noticed between FF and Chrome is when I click a link which takes me to a specific post in a page using FF the nav bars take longer to load than in Chrome. More accurately, in both browsers they initially appear with the top bar full sized for an instant then both disappear completely, then reappear with the top bar the same size as the second bar. This takes longer in FF, and I suspect they never reappear on those times I've noticed them absent. I'm not sure if they've disappeared after I've started scrolling, I'm trying to pay closer attention and not scroll immediately.
     
  10. HankLloydRight

    HankLloydRight No Roads

    Joined:
    Jan 18, 2014
    Messages:
    11,561
    Location:
    Connecticut
    Just another tiny nit on the nav -- on mobile (iPhone 6), when opening an old watched thread, I can't seem to find "go to first unread" link like there is on the desktop. So I end up going to the last page and scrolling up to find the most recent post(s).
     
  11. danny

    danny Administrator

    Joined:
    Aug 15, 2006
    Messages:
    1,138
    Location:
    California
    Can't really reproduce this on my end. Seems to work for me fine when clicking on links in the watched threads list. There are also the red dots and left side avatar which should do the same thing for you.

    Anyone else having a similar issue?
     
  12. JRP3

    JRP3 Hyperactive Member

    Joined:
    Aug 20, 2007
    Messages:
    15,663
    Location:
    Central New York
    OK just caught it happening on this page, the bars are there initially but as I scroll down they both disappear, and they will reappear when I scroll back up to the point where they disappeared. If I scroll back down again they disappear again. I know the top bar is supposed to hide when you scroll down, it seems as if sometimes the lower bar goes away with it. Only in FF so far, not in Chrome.
     
    • Helpful x 1
  13. HankLloydRight

    HankLloydRight No Roads

    Joined:
    Jan 18, 2014
    Messages:
    11,561
    Location:
    Connecticut
    Yes, clicking on the links (thread titles) works great.. most of the time. But if I haven't visited a thread in 30 days (or longer) the "go to last unread" high-water marker is lost, and at least on the desktop, clicking the thread title takes me to Post #1. Doug explained this is by design. So when this happens (on the desktop), there's always a "go to first unread" link, which when clicked does what it says. So it's two steps for older threads not viewed in a while. I can live with that.

    The problem is on mobile, when opening the old thread to post #1, there is no "go to first unread" link to click. So I have to do as I said and go to the last page and hunt for the most recent post and start reading there.

    You have to find an old thread you haven't visited in a while in "watched threads", click on it (on mobile), and see where it takes you. Then try to find the most recent post.

    Also, clicking the little red dot on an iphone? Have you tried that?
     
  14. danny

    danny Administrator

    Joined:
    Aug 15, 2006
    Messages:
    1,138
    Location:
    California
    Yeah, but that is why we enabled the last unread function for the left side avatar. Have you tried that when on mobile?
     
  15. HankLloydRight

    HankLloydRight No Roads

    Joined:
    Jan 18, 2014
    Messages:
    11,561
    Location:
    Connecticut
    Ok, but I think people mentioned this before... the intuitive thing to do to open threads is click on the thread title, especially on mobile since it's large and easy to "click". But I don't know ahead of time if a thread "last unread" flag has timed-out. So how would I know to click there, instead of the obvious place being the thread title to get to the last unread post?

    So wait, I don't get it then.. if the avatar icon always takes you to the last unread post (even if it timed-out), why doesn't the thread title do the same thing? What's the purpose of the time-out then?

    Why would anyone, ever, want to go to the first post if they haven't read a watched thread in 30 days or more?
     
  16. ohmman

    ohmman Maximum Plaid Member

    Joined:
    Feb 13, 2014
    Messages:
    8,460
    Location:
    North Bay, CA
    I have the same situation as @HankLloydRight on mobile. Tapping the avatar to the left brings up my profile "popup", it doesn't take me to the latest unread - at least as far as I can tell. Maybe those are threads that I've read within the last 30 days? If so, that's inconsistent and a little confusing.
     
  17. HankLloydRight

    HankLloydRight No Roads

    Joined:
    Jan 18, 2014
    Messages:
    11,561
    Location:
    Connecticut
    It's even more interesting. In threads you have participated in, where your avatar is a little circle, clicking the avatar box brings up your profile. But if you didn't participate in the thread at all, the avatar brings up last unread. I don't know about most people, but I've participated in most "watched threads" but not all.
     
  18. Dave EV

    Dave EV Active Member

    Joined:
    Jun 23, 2009
    Messages:
    1,296
    Location:
    San Diego
    I'm still seeing the issue where if you jump to a specific post, the top of the post (post number, timestamp, etc) is hidden under the navigation bar.

    Happens if you click on a link to a specific post, or often when you use the new posts page and then jump to the first unread post.
     
  19. JRP3

    JRP3 Hyperactive Member

    Joined:
    Aug 20, 2007
    Messages:
    15,663
    Location:
    Central New York
    Same for me.
     
  20. ohmman

    ohmman Maximum Plaid Member

    Joined:
    Feb 13, 2014
    Messages:
    8,460
    Location:
    North Bay, CA
    I can't find any threads I haven't participated in. ;)

    You've got it right. This definitely seems to be a strange aspect of the interface, and since @danny doesn't typically participate in the vehicle threads, might explain why he couldn't reproduce it.

    I suggest adding a "go to last unread" selection like the desktop version, or quite honestly, moving both mobile and desktop to always navigate to the newest post. I mean, who ever wants to start over?
     
    • Love x 1

Share This Page

  • About Us

    Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.
  • Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


    SUPPORT TMC