Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

Upgraded MCU1 to MCU2 - Are you experiencing New Problems?

brkaus

Well-Known Member
Jul 8, 2014
8,097
6,650
Austin, TX
Sometimes I get in the car it says data connection. Connects pretty quickly.

This seams new to me. I’m curious if the app would connect in this state or not.
 

AustinP

Active Member
Apr 6, 2015
1,312
1,055
Belgium
So a followup to my previous post.

Ranger came by today for my Text Messaging issue (#3 in previous post).
He is driving an original P85D, modified as a service car. He had the MCU2 upgrade.

His visit answered both issue #2 & #3

1) Text Messaging: He could replicate the issue with his phone in his car. Ergo, this is not just my car. He did not find anything similar in their KB, hence he created a new case. So this is now the waiting game for the next update with "minor fixes"

2) LTE: As he was trying voice, he did not have coverage. He immediately told me that it's like that for any MCU2, whether "original builtin" as for all S/X since April 2018, or for upgrade like mine and his.
I'm quite surprised here. Owner of S/X with MCU2 just accept this? It would mean 3 years and not enough complain, so this is not being fixed? Feels like this one will never be fixed, and it's crazy.

So to whomever recognise this: "The MCU2 easily don't find LTE or 3G. Almost every time I get in the car, it will not find LTE immediately. After about a minute it connects.", please complain to your SeC. The more attention it get, the more traction it will have.

One thing I saw over the years, is that Tesla is listening, but we have to be loud enough to have the issue pulled out of the back log and into the next sprint.
So there is good news about my LTE issue (point 2 previously reported), and it looks it solved it for others too. Since update .24, LTE is working perfectly, and connection is immediately available. No more 2-3 minutes of silence before streams would start.

About point 1), still not solved. The best workaround I found is that I can ask "Write Text" ("Envoyer un message" in french). This opens the phone app on the MCU, where I can select my Favourites and start messaging one of them. Not ideal, but safest until it is fixed.
 
  • Like
Reactions: bhzmark

Ron Burgundy

Member
Jan 31, 2020
66
65
Seattle
I'd really be interested in your experiences upgrading to mcu2 with an early Signature Car. I'm assuming that's the one you upgraded
I upgraded my Signature to MCU2 a couple of months ago.
Everything has been a positive improvement and experience until recently - the last month.
The streaming of audio (music specifically) is wonky!
I will have 3-4-5 bars of LTE, yet a song will start, and then skip to the next song.
Or the song will not play at all.
Or I will get a "connectivity error"

This was infrequent initially about two months ago, but now it is almost every other song!

The audio/connectivity issue does not happen when streaming video.

This is happening on the other models (3/Y/X) too, as I found complaints here n the board.
I have not heard about any formal response from Tesla though (maybe it is here on the board somewhere, but I have not found it yet)
 
Last edited:

hybridbear

Member
Oct 6, 2015
751
304
Minneapolis
I upgraded my Signature to MCU2 a couple of months ago.
Everything has been a positive improvement and experience until recently - the last month.
The streaming of audio (music specifically) is wonky!
I will have 3-4-5 bars of LTE, yet a song will start, and then skip to the next song.
Or the song will not play at all.
Or I will get a "connectivity error"

This was infrequent initially about two months ago, but now it is almost every other song!

The audio/connectivity issue does not happen when streaming video.

This is happening on the other models (3/Y/X) too, as I found complaints here n the board.
I have not heard about any formal response from Tesla though (maybe it is here on the board somewhere, but I have not found it yet)
What software version do you have? Cars with MCU1 I believe are no longer receiving software updates. But with MCU2 on an older car are you getting software updates again? What about the dash power display & speedometer? Did it change from the old style to the new style with MCU2?
 
  • Like
Reactions: tccartier

Ron Burgundy

Member
Jan 31, 2020
66
65
Seattle
What software version do you have? Cars with MCU1 I believe are no longer receiving software updates. But with MCU2 on an older car are you getting software updates again? What about the dash power display & speedometer? Did it change from the old style to the new style with MCU2?
I am on s/w ver 2021.24.5.
I am getting ota updates - 2 in the last 10 days.
As far as the look or layout of the IC or center screen - nothing major changed that I can recall, but it has been about 4 months since the MCU2 update.
The power display and speedo seem to be the same as before.
 

Anth89

Member
Mar 12, 2021
6
4
Riedisheim, France
I made the upgrade to MCU2 in July, including radio.
I have a 100D, first registration October 2017 in France (so manufacturing date probably July-August 2017).

I am experiencing since the upgrade random freezes (both screens) and reboots, more or less one per week. One even happened during driving on the motorway. It seems temperature (supercharge in August) or heavier load (kids playing video games, using internet) plays a role.

This happened both with software version 2021.12.25.7 and with the latest update 2021.24.5.

Any thoughts or similar experience? Can some MCU2 users testify whether they can play more than 5-10 minutes without having problems?
The LTE connection is also often disabled when starting the car. Usually reconnect after 1-2 minutes.

I have opened a request through the Tesla App, they're investigating remotely for more than one week now, without results.
 

AustinP

Active Member
Apr 6, 2015
1,312
1,055
Belgium
I made the upgrade to MCU2 in July, including radio.
I have a 100D, first registration October 2017 in France (so manufacturing date probably July-August 2017).

I am experiencing since the upgrade random freezes (both screens) and reboots, more or less one per week. One even happened during driving on the motorway. It seems temperature (supercharge in August) or heavier load (kids playing video games, using internet) plays a role.

This happened both with software version 2021.12.25.7 and with the latest update 2021.24.5.

Any thoughts or similar experience? Can some MCU2 users testify whether they can play more than 5-10 minutes without having problems?
The LTE connection is also often disabled when starting the car. Usually reconnect after 1-2 minutes.

I have opened a request through the Tesla App, they're investigating remotely for more than one week now, without results.
The LTE connection issue has vastly improved since around the time 2021.24.4 was installed. It still happens, but much more rare.
I don't experience any reboots, but I have an AP1 car, so MCU2 doesn't need to do Sentry or Dashcam apps, or NoA stuff.
I'd argue those puts additional loads on MCU2 for AP2.x/AP3.x cars, and potentially crashes.

Opening a request in the Tesla App is indeed the only way I know of to reach to Tesla and draw their attention to such issue. And hopefully fix them. (which they did for the dark backup camera and improved LTE stability)
 
  • Like
Reactions: WhiteWi

AaronE

Member
Mar 8, 2019
32
24
California
I upgraded my Signature to MCU2 a couple of months ago.
Everything has been a positive improvement and experience until recently - the last month.
The streaming of audio (music specifically) is wonky!
I will have 3-4-5 bars of LTE, yet a song will start, and then skip to the next song.
Or the song will not play at all.
Or I will get a "connectivity error"

This was infrequent initially about two months ago, but now it is almost every other song!

The audio/connectivity issue does not happen when streaming video.

This is happening on the other models (3/Y/X) too, as I found complaints here n the board.
I have not heard about any formal response from Tesla though (maybe it is here on the board somewhere, but I have not found it yet)
MCU2 upgraded 2015 P85D here, and yes, this just started happening to me today. It's almost every song. I'm still on 2021.4.18 but it's prompting me to install the already downloaded 2021.24.5. I haven't yet since I came here to survey all the batterygate/accelerationgate/chargegate issues before I bit the bullet...
 
  • Funny
Reactions: WhiteWi

Anth89

Member
Mar 12, 2021
6
4
Riedisheim, France
After a few days and some exchanges about the freezes, I received a feedback from the service center. The issue should now be solved with the 2021.32.10 update, which my car received a few days ago. So far I did not have any freeze - let's see how this goes in the coming days.
 

WhiteWi

Supporting Member
Supporting Member
Feb 21, 2021
603
472
Somewhere in Universe
After a few days and some exchanges about the freezes, I received a feedback from the service center. The issue should now be solved with the 2021.32.10 update, which my car received a few days ago. So far I did not have any freeze - let's see how this goes in the coming days.
Unfortunately freezes still happen even with latest firmware.
 

cousin_IT

Face provided by boredhumans.com
Oct 27, 2020
360
278
Netherlands
Firmware did not resolve much, I do appreciate the new dynamic sound option (I have premium audio). 4G still is unavailable 50% of the time you get in the car, sometimes Spotify does not load. Yet to test the bluetooth connectivity of my other iPhone.
 

hybridbear

Member
Oct 6, 2015
751
304
Minneapolis
After a few days and some exchanges about the freezes, I received a feedback from the service center. The issue should now be solved with the 2021.32.10 update, which my car received a few days ago. So far I did not have any freeze - let's see how this goes in the coming days.
Be aware that there are potentially other issues with 2021.32.10.
 

hybridbear

Member
Oct 6, 2015
751
304
Minneapolis
Firmware did not resolve much, I do appreciate the new dynamic sound option (I have premium audio). 4G still is unavailable 50% of the time you get in the car, sometimes Spotify does not load. Yet to test the bluetooth connectivity of my other iPhone.
Our car has started having these issues with LTE since the 2021.24 series of firmware. We'll have it go offline randomly while parked outside with a strong LTE signal. Sometimes when driving it will fail to load traffic data for navigation & Spotify will also fail. Things were great until the 2021.24 firmware.
 

Ron Burgundy

Member
Jan 31, 2020
66
65
Seattle
I got updated to 2021.32.10 last week.
1. It did not fix the streaming radio skipping songs or showinf connectivity error (with 4-5 bars of signal) I am told by the SC that it is a known buffereing issue. And I thought getting [email protected] would have a HUGE bufffer... :)
2. I also now have no menu for auto wipers to be turned on.
The Tech guys pushed 2021.32.10 again, thinking that maybe it did not fully install.

Both issues are "being looked at".
 

oktane

Active Member
Oct 25, 2016
1,787
2,573
USA
My car will randomly skip to the next song (as if I pushed the button on the wheel but didn't). Also, I can't remote unlock or open frunk/trunk, but horn and windows work fine. Weird.
 

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top