TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

I need input from fellow MX owners

Discussion in 'Model X' started by jdk325, Apr 5, 2019.

  1. jdk325

    jdk325 Member

    Joined:
    Oct 13, 2015
    Messages:
    34
    Location:
    Suwanee, Georgia
    I am getting frustrated and could use some input. I have owned 4 Tesla's over the years. I started with a Model S 60, then went to a Model S 75D, then to a Model 3 LR RWD, and then in September 2018 I got a Model X P100D (this was an inventory vehicle - I was told when I was buying it that it had MCU 2.0, but after taking delivery it seemed pretty sluggish and and the service center confirmed that it was one of the last off the line with the MCU 1.0 - March 2018 build).

    On the Model X, I have had both the 17" screen and MCU replaced already, but I continue to have issues. Voice Control works about 10% of the time. By work, I mean that when I hit the button it actually listens to me and works. The other 90% of the time I just get the spinning circle showing that it is trying to activate Voice Control but won't work and just keeps spinning or says "Try Again". The streaming radio service works, but I always have skipping or digitizing that happens when listening. If I am listening to music from my iPhone or the radio, no issues. Additionally, the screen can just be downright unresponsive taking multiple taps to get something to respond. This stuff happened before and after the MCU and screen replacement.

    I have taken my MX to the service center several times for these issue (hence the last time they replaced the MCU). However, I went to the service center yesterday because after I got 2019.8.3, I had so many software glitches that I was losing my patience. I had them all documented with video so that I could show the service center. I kid you not when I say this, but I was told yesterday by the service center that Tesla is like a start up software company and that these are all software issues that they are continuously working to resolve. As a long time owner, I can accept that there will be glitches and I am okay with that. But I never had consistent Voice Control issues or streaming music issues in any of my other Tesla's.

    I just want to know if am I alone with all of these issues and I have a bigger problem or is this truly something that all MX owners are experiencing right now?

    I really appreciate the feedback.
     
  2. VikH

    VikH Supporting Member

    Joined:
    Nov 23, 2015
    Messages:
    805
    Location:
    Midwest, USA
    I have voice control issues too and therefore do not use it. I don't have issues with streaming radio and unresponsiveness of the screen though. I am on 2019.8.4 (MCU1) and do not have any software glitches.

    Sorry to hear they are giving you the run around. I get irritated by what Tesla service deems "normal". Seems like they are taking that stance to an extreme here.
     
  3. AZMurph

    AZMurph Member

    Joined:
    Mar 21, 2019
    Messages:
    26
    Location:
    USA
    I just bought a Dec 2018 build 75D and don’t have anything like that, but I assume it’s MCU 2. Only thing I’ve had is the squeaky 2nd row seat issue and if I floor it in Standard suspension I get the shudder. But no shudder in normal aggressive driving or at all in Low suspension. SC fixed the seat. So, really happy so far.
     
  4. Ryshaw

    Ryshaw Member

    Joined:
    Apr 5, 2017
    Messages:
    72
    Location:
    Scottsdale, AZ
    Hi JDK, and sorry you are having the issues you outlined. The only issue that I've experienced is the Voice Control issue. I've deemed it virtually useless (which is no different than the BMW that I owned prior, btw). I do also at times have issue with the web browser, which becomes unresponsive, but this is usually corrected by a hard reboot. It is somewhat frustrating to see performance of MCU2 on my buddies M3, as it seems to be very snappy, and without the lag issues that we see with MCU1.

    Hope you are able to get this resolved soon!
     
  5. aesculus

    aesculus Still Trying to Figure This All Out

    Joined:
    May 31, 2015
    Messages:
    4,078
    Location:
    Northern California
    My AP1 MX90D works well with voice commands for calling and navigation. Don't use it for the media as that never really worked IMHO. I am on 2018.50.x sw.
     
  6. boaterva

    boaterva Supporting Member

    Joined:
    Apr 2, 2016
    Messages:
    7,473
    Location:
    Northern Virginia, USA
    All I can say is wait a few days until you get 2019.8.4 or 5. 3 is supposed to be a problem and was even pulled from some cars (like our Model 3). 2019.8.4 and 5 are rolling out quickly and should fix some of these issues. Then you should be able to get others corrected.
     
  7. jboy210

    jboy210 Supporting Member

    Joined:
    Dec 2, 2016
    Messages:
    3,871
    Location:
    Northern California
    Ah. That explains why I got 8.4 two days after getting 8.3.
     
  8. jdk325

    jdk325 Member

    Joined:
    Oct 13, 2015
    Messages:
    34
    Location:
    Suwanee, Georgia
    I was having these issues prior to 2019.8.3. After that update, I had so many glitches that Tesla pushed 8.4 as soon as it was available. That fixed some of the other issues I was having associated with 8.3, but no change to the voice control, music skipping or browser problems.
     
  9. lynnpt2001

    lynnpt2001 Cookie Monster MX & M3

    Joined:
    Sep 9, 2015
    Messages:
    461
    Location:
    Greencastle PA
    I'm on 2019.9, got mine in July 18, MCU2, never seen any issues like this to this point and none now....press for a replacement of the main computer.
     
  10. dethman

    dethman Member

    Joined:
    Apr 19, 2018
    Messages:
    883
    Location:
    socal
    No similar issues on mcu2. Buggy on all sorts of other ways but not on voice control
     
  11. jboy210

    jboy210 Supporting Member

    Joined:
    Dec 2, 2016
    Messages:
    3,871
    Location:
    Northern California
    Mine is working fine. May 2018 build.
     
  12. GalaxySurfer

    GalaxySurfer Life, The Universe and Everything.

    Joined:
    Oct 10, 2018
    Messages:
    229
    Location:
    Oregon
    Late August 2018 MX P100D

    The _only_ issue ive had, i only noticed a few days ago.

    The passenger side backseat FWD button doesnt work. The door works, just not the interior button.

    Since i rarely have backseat
    passengers, and i can control the door from the front i havent considered it a big deal, if/when i ever have another reason to go to the SC i will mention it tho.

    All in all tho im very pleased with my car and find it quite reliable.
     
  13. dgatwood

    dgatwood Member

    Joined:
    Dec 20, 2017
    Messages:
    704
    Location:
    Sunnyvale, ca
    You're not alone. When the cell network is misbehaving, that happens, and depending on where you are, that can range from rare to continuous. It has been happening for me more than half the time ever since updating from 2018.50.6 to 2019.8.3. I'm not sure if it is a bug in the release or if I'm just noticing it more because 2019.8.3 is causing me to submit bug reports so much more often....

    Either way, yes, voice control seems to be almost useless in 2019.8.x so far, at least for me. Maybe 2019.8.5 will help, but I doubt it. I suspect we'll have to get a subsequent update to 2019.12.x before anything will improve.

    Put it this way, this was the only time I've ever actually shouted "bug report" at the top of my lungs because my car kept failing to process voice input, before finally giving up after five or six tries and rebooting the thing for the second or third time that day.

    2019.8.3 should never have been rolled out. Never.
     
  14. Lhshockey24

    Lhshockey24 Member

    Joined:
    Nov 25, 2017
    Messages:
    633
    Location:
    Livermore, CA + Lake Tahoe
    May 2017 build X, back when they did really well to build quality cars before all efforts went into the 3. Have literally had zero issues with the car's MCU or voice command. (Still had the half-shafts replaced since it's a P100D)
     

Share This Page

  • About Us

    Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.
  • Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


    SUPPORT TMC